The installation of PostgreSQL is not difficult. However, there are some software requirements that you will need for the PostgreSQL compilation. All of the requirements, outside of the PostgreSQL source code are GNU tools. If you are running Linux, there is a good chance that the tools are already installed. If you are running a BSD derivative such as FreeBSD or MacOS X you may have to download the tools. If you find that you are missing any of the required components, first check your vendor website for the packages, otherwise you may download them from http://www.gnu.org. The following is a list of required packages.